jQuery Migrate

jQuery版本迁移辅助插件,用jquery不同版本开发的程序在修改jquery版本出现的兼容问题可以使用jQuery Migrate解决此问题

jQuery官网CDN

支持版本3.0.0, 3.0.0-rc1, 1.4.1, 1.4.0, 1.3.0, 1.2.1, 1.2.0, 1.1.1, 1.1.0
<script src="http://code.jquery.com/jquery-migrate-3.0.0.min.js"></script>

BootCDN

支持版本3.0.0, 3.0.0-rc1, 1.4.1, 1.4.0, 1.3.0, 1.2.1, 1.2.0, 1.1.1, 1.1.0, 1.0.0, 
<script src="http://cdn.bootcss.com/jquery-migrate/3.0.0/jquery-migrate.min.js"></script>   

jQuery

jQuery官方CDN

支持版本3.4.0, 3.3.1, 3.2.1, 3.2.0, 3.1.1, 3.0.0, 2.1.4, 2.1.1, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.10.2, 1.10.1, 1.10.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.6, 1.5.2, 1.5.1, 1.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4, 1.3.2, 1.3.1, 1.3, 1.2.6, 1.2.3
<script src="http://code.jquery.com/jquery-3.4.0.min.js"></script>

百度CDN

支持版本2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.6, 1.2.3, 1.11.3, 1.11.1, 1.10.2, 1.10.1, 1.10.0
<script src="http://apps.bdimg.com/libs/jquery/2.1.4/jquery.min.js"></script>

微软CDN

支持版本3.4.0, 3.3.1, 3.2.1, 3.2.0, 3.1.1, 3.1.0, 3.0.0, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.12.4, 1.12.3, 1.12.2, 1.12.1, 1.12.0, 1.11.3, 1.11.2, 1.11.1, 1.11.0, 1.10.2, 1.10.1, 1.10.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.6, 1.5.2, 1.5.1, 1.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4, 1.3.2
<script src="http://ajax.aspnetcdn.com/ajax/jQuery/jquery-3.2.1.min.js"></script>

BootCDN

支持版本3.4.0, 3.3.1, 3.2.1, 3.2.0, 3.1.1, 3.1.0, 3.0.0, 3.0.0-rc1, 3.0.0-beta1, 3.0.0-alpha1, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.1-rc2, 2.1.1-rc1, 2.1.1-beta1, 2.1.0, 2.1.0-rc1, 2.1.0-beta3, 2.1.0-beta2, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.12.4, 1.12.3, 1.12.2, 1.12.1, 1.12.0, 1.11.3, 1.11.2, 1.11.1, 1.11.1-rc2, 1.11.1-rc1, 1.11.1-beta1, 1.11.0, 1.11.0-rc1, 1.11.0-beta3, 1.10.2, 1.10.1, 1.10.0, 1.9.1, 1.9.0, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7, 1.6.4, 1.6.3, 1.6.2, 1.6.1, 1.5.1, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.6, 1.2.3
<script src="http://cdn.bootcss.com/jquery/3.3.1/jquery.min.js"></script>

jQueryUi

jQuery官方CDN

支持版本1.12.1, 1.12.0, 1.11.4, 1.11.3, 1.11.2, 1.11.1, 1.11.0, 1.10.4, 1.10.3, 1.10.2, 1.10.1, 1.10.0, 1.9.2, 1.9.1, 1.9.0, 1.8.24, 1.8.23, 1.8.22, 1.8.21, 1.8.20, 1.8.19, 1.8.18, 1.8.17, 1.8.16, 1.8.15, 1.8.14, 1.8.13, 1.8.12, 1.8.11, 1.8.10, 1.8.9, 1.8.8, 1.8.7, 1.8.6, 1.8.5, 1.8.4, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.3, 1.7.2, 1.7.1, 1.7.0
<script src="http://code.jquery.com/ui/1.12.1/jquery-ui.min.js"></script>

百度CDN

支持版本1.10.2, 1.10.1, 1.10.0, 1.9.2, 1.9.1, 1.9.0, 1.8.24, 1.8.23, 1.8.22, 1.8.21, 1.8.19, 1.8.18, 1.8.17, 1.8.16, 1.8.15, 1.8.14, 1.8.13, 1.8.12, 1.8.11, 1.8.10, 1.8.9, 1.8.8, 1.8.7, 1.8.6, 1.8.5, 1.8.4, 1.8.2, 1.8.1, 1.8.0, 1.7.3, 1.7.2, 1.7.1, 1.7.0, 1.6.0, 1.5.3, 1.5.2 
<script src="http://apps.bdimg.com/libs/jqueryui/1.9.2/jquery-ui.min.js"></script>

微软CDN

支持版本1.12.1, 1.12.0, 1.11.4, 1.11.3, 1.11.2, 1.11.1, 1.11.0, 1.10.4, 1.10.3, 1.10.2, 1.10.1, 1.10.0, 1.9.2, 1.9.1, 1.9.0, 1.8.24, 1.8.23, 1.8.22, 1.8.21, 1.8.20, 1.8.19, 1.8.18, 1.8.17, 1.8.16, 1.8.15, 1.8.14, 1.8.13, 1.8.12, 1.8.11, 1.8.10, 1.8.9, 1.8.8, 1.8.7, 1.8.6, 1.8.5
<script src="http://ajax.aspnetcdn.com/ajax/jquery.ui/1.12.1/jquery-ui.min.js"></script>

BootCDN

支持版本1.12.1, 1.12.0, 1.12.0-rc.2, 1.12.0-rc.1, 1.12.0-beta.1, 1.11.4, 1.11.3, 1.11.2, 1.11.1, 1.11.0, 1.10.4, 1.10.3, 1.10.2, 1.10.1, 1.10.0, 1.9.2, 1.9.1, 1.9.0, 1.8.24, 1.8.23, 1.8.21, 1.8.19, 1.8.18, 1.8.17, 1.8.16, 1.8.13
<script src="http://cdn.bootcss.com/jqueryui/1.12.1/jquery-ui.min.js"></script>

Highcharts

Highcharts官方CDN

支持版本5.0.12, 5.0.11, 5.0.10, 5.0.9, 5.0.8, 5.0.7, 5.0.6, 5.0.5, 5.0.4, 5.0.3, 5.0.2, 5.0.1, 5.0.0,4.2.7, 4.2.6, 4.2.5, 4.2.4, 4.2.3, 4.2.2, 4.2.1, 4.2.0, 4.1.10, 4.1.9, 4.1.8, 4.1.7, 4.1.6, 4.1.5, 4.1.4, 4.1.3, 4.1.2, 4.1.1, 4.1.0, 4.0.4, 4.0.3, 4.0.1, 4.0.0, 3.0.10, 3.0.9, 3.0.8, 3.0.7, 3.0.6, 3.0.5, 3.0.4, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 2.3.5, 2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.5, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.6, 2.1.5, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0,  
<script src="http://code.highcharts.com/5.0.12/highcharts.js"></script>

百度CDN

支持版本2.3.5, 2.2.5
<script src="http://apps.bdimg.com/libs/highcharts/2.2.5/highcharts.js"></script>  

BootCDN

支持版本5.0.12, 5.0.11, 5.0.10, 5.0.9, 5.0.8, 5.0.7, 5.0.6, 5.0.5, 5.0.4, 5.0.3, 5.0.2, 5.0.1, 5.0.0,4.2.7, 4.2.6, 4.2.5, 4.2.4, 4.2.3, 4.2.2, 4.2.1, 4.2.0, 4.1.10, 4.1.9, 4.1.8, 4.1.7, 4.1.6, 4.1.5, 4.1.4, 4.1.3, 4.1.2, 4.1.1, 4.1.0, 4.0.4, 4.0.3, 4.0.1, 4.0.0, 3.0.10, 3.0.9, 3.0.7, 3.0.2, 2.3.5, 2.3.1, 2.2.5, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.6, 2.1.5
<script src="http://cdn.bootcss.com/highcharts/5.0.12/highcharts.js"></script>

jqMobi

百度CDN

支持版本1.0.0
<script src="http://apps.bdimg.com/libs/jqmobi/1.0.0/jq.ui.min.js"></script>
<script src="http://apps.bdimg.com/libs/jqmobi/1.0.0/jq.mobi.min.js"></script>

jQuery mobile

jQuery mobile官方CDN

支持版本1.5.0-alpha.1, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.4.0-rc.1, 1.4.0-beta.1, 1.4.0-alpha.2, 1.4.0-alpha.1,  1.3.2, 1.3.1, 1.3.0, 1.3.0-rc.1, 1.3.0-beta.1, 1.2.1, 1.2.0, 1.2.0-rc.2, 1.2.0-rc.1, 1.2.0-beta.1, 1.2.0-alpha.1, 1.1.2, 1.1.1, 1.1.1-rc.1, 1.1.0, 1.1.0-rc.2, 1.1.0-rc.1, 1.0.1, 1.0.0, 1.0.0-rc3, 1.0.0-rc2, 1.0.0-rc1, 1.0.0-b3, 1.0.0-b2, 1.0.0-b1, 1.0.0-a4.1, 1.0.0-a4, 1.0.0-a3, 1.0.0-a2, 1.0.0-a1 
<script src="http://code.jquery.com/mobile/1.4.5/jquery.mobile-1.5.0-alpha.1.js"></script>

百度CDN

支持版本1.4.5, 1.4.3, 1.4.2 , 1.3.0, 1.1.1, 1.0.1
<script src="http://apps.bdimg.com/libs/jquerymobile/1.4.5/jquery.mobile-1.4.5.min.js"></script>

微软CDN

支持版本1.4.5, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.1, 1.3.0, 1.2.0, 1.1.2, 1.1.1, 1.1.0, 1.1.0 rc2
<script src="http://ajax.aspnetcdn.com/ajax/jquery.mobile/1.4.5/jquery.mobile-1.4.5.js"></script>

BootCDN

支持版本1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.1, 1.2.0
<script src="http://cdn.bootcss.com/jquery-mobile/1.4.5/jquery.mobile.min.js"></script>

Bootstrap

BootCDN

支持版本4.0.0-alpha.6, 4.0.0-alpha.5, 4.0.0-alpha.4, 4.0.0-alpha.3, 4.0.0-alpha.2, 4.0.0-alpha, 3.3.7, 3.3.6, 3.3.5, 3.3.4, 3.3.2, 3.3.1, 3.3.0, 3.2.0, 3.1.1, 3.1.0, 3.0.3, 3.0.2, 3.0.1, 3.0.0, 3.0.0-rc2, 3.0.0-rc1, 2.3.2, 2.3.1, 2.3.0, 2.2.2, 2.2.1, 2.1.1, 2.1.0, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 1.4.0, 
<script src="http://cdn.bootcss.com/bootstrap/4.0.0-alpha.6/js/bootstrap.min.js"></script>
<link href="http://cdn.bootcss.com/bootstrap/4.0.0-alpha.6/css/bootstrap.min.css" rel="stylesheet">

百度CDN

支持版本3.3.4, 3.3.0, 3.2.0, 3.1.1, 3.0.3, 2.3.2, 2.3.1, 2.2.1, 2.1.1, 2.0.4 , 2.0.3 , 2.0.2
<script src="http://apps.bdimg.com/libs/bootstrap/3.3.4/js/bootstrap.min.js"></script>
<link href="http://apps.bdimg.com/libs/bootstrap/3.3.4/css/bootstrap.min.css" rel="stylesheet">

dojo

百度CDN

支持版本1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.4, 1.7.3, 1.7.2, 1.7.1, 1.7.0, 1.6.1, 1.6.0, 1.5.1, 1.5.0, 1.4.3, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.3, 1.2.0, 1.1.1
<script src="http://apps.bdimg.com/libs/dojo/1.8.3/dojo.js.uncompressed.js"></script>

BootCDN

支持版本1.11.0-rc5, 1.11.0-rc4, 1.11.0-rc3, 1.11.0-rc2, 1.11.0-rc1, 1.10.4, 1.10.3, 1.10.2, 1.10.1, 1.10.0, 1.9.7, 1.9.6, 1.9.5, 1.9.4, 1.9.3, 1.9.2, 1.9.1, 1.9.0, 1.8.10, 1.8.9, 1.8.8, 1.8.7, 1.8.6, 1.8.5, 1.8.4,  1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.8, 1.7.7, 1.7.6, 1.7.5, 1.7.4, 1.7.3, 1.7.2, 1.7.1, 1.7.0, 1.6.3, 1.6.2, 1.6.1, 1.6.0, 1.5.4, 1.5.3, 1.5.2, 1.5.1, 1.5.0, 1.4.6, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.3, 1.3.2, 1.3.1, 1.3.0
<script src="http://cdn.bootcss.com/dojo/1.11.0-rc5/dojo.js.uncompressed.js"></script>

ext-core

百度CDN

支持版本3.1.0
<script src="http://apps.bdimg.com/libs/ext-core/3.1.0/ext-core.js"></script>

BootCDN

支持版本3.1.0, 3.0.0
<script src="http://cdn.bootcss.com/ext-core/3.1.0/ext-core.min.js"></script>

Highstock

BootCDN

支持版本5.0.12, 5.0.11, 5.0.10, 5.0.9, 5.0.8, 5.0.7, 5.0.6, 5.0.5, 5.0.4, 5.0.3, 5.0.2, 5.0.1, 5.0.0, 4.2.7, 4.2.6, 4.2.5, 4.2.4, 4.2.3, 4.2.2, 4.2.1, 4.2.0, 2.1.10, 2.1.9, 2.1.8, 2.1.7, 2.1.6, 2.1.5, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.0.4, 2.0.3, 2.0.1, 2.0.0, 1.3.10, 1.3.7, 1.2.4
<script src="http://cdn.bootcss.com/highstock/5.0.12/highstock.js"></script>

JSON

百度CDN

支持版本json2
<script src="http://apps.bdimg.com/libs/json/json2/json2.js"></script>

BootCDN

支持版本20160511, 20150503, 20140204, 20130526, 20121008, 20120620, 20110223, 
<script src="http://cdn.bootcss.com/json2/20160511/json2.min.js"></script>

backbone

百度CDN

支持版本1.1.2, 1.1.1, 1.1.0, 1.0.0, 0.9.9-amdjs, 0.9.9, 0.9.2-amdjs, 0.9.2, 0.9.10, 0.9.1-amdjs, 0.9.1, 0.9.0, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.5, 0.3.3
<script src="http://apps.bdimg.com/libs/backbone.js/1.1.2/backbone-min.js"></script>

BootCDN

支持版本1.3.3, 1.3.2, 1.3.1, 1.2.3, 1.2.2, 1.2.1, 1.2.0, 1.1.2, 1.1.1, 1.1.0, 1.0.0, 0.9.10, 0.9.9, 0.9.9-amdjs, 0.9.2, 0.9.2-amdjs, 0.9.1, 0.9.1-amdjs, 0.9.0, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.5, 0.3.3, 0.3.2, 0.3.1, 0.3.0, 0.2.0, 0.1.2, 0.1.1 
<script src="http://cdn.bootcss.com/backbone.js/1.3.3/backbone-min.js"></script>

lesscss

百度CDN

支持版本1.3.0
<script src="http://apps.bdimg.com/libs/lesscss/1.3.0/less.min.js"></script>

BootCDN

支持版本3.0.0-pre.4, 3.0.0-pre.3, 3.0.0-pre.2, 3.0.0-pre.1, 3.0.0-alpha.2, 3.0.0-alpha.1, 2.7.2, 2.7.1, 2.7.0, 2.6.1, 2.6.0, 2.5.3, 2.5.2, 2.5.1, 2.5.0, 2.4.0, 2.3.1, 2.3.0, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.0, 2.0.0-b3, 2.0.0-b2, 2.0.0-b1, 1.7.5, 1.7.4, 1.7.3, 1.7.2, 1.7.1, 1.7.0, 1.6.3, 1.6.2, 1.6.1, 1.6.0, 1.5.1, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.3, 1.3.2, 1.3.1, 1.3.0, 1.2.2, 1.2.1, 1.2.0, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.41
<script src="http://cdn.bootcss.com/less.js/3.0.0-pre.4/less.min.js"></script>

mootools

百度CDN

支持版本1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.0, 1.2.5, 1.2.4, 1.2.3, 1.2.2, 1.2.1, 1.1.2, 1.1.1
<script src="http://apps.bdimg.com/libs/mootools/1.4.5/mootools-yui-compressed.js"></script> 

BootCDN

支持版本1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.5, 1.3.2
<script src="http://cdn.bootcss.com/mootools/1.6.0/mootools-core.min.js"></script> 

QUnit

百度CDN

支持版本1.9.0
<script src="http://apps.bdimg.com/libs/quint/1.9.0/qunit.js"></script>   

BootCDN

支持版本2.3.3, 2.3.2, 2.3.1, 2.3.0, 2.2.1, 2.2.0, 2.1.1, 2.1.0, 2.0.1, 2.0.0, 2.0.0-rc1, 1.23.1, 1.23.0, 1.22.0, 1.21.0, 1.20.0, 1.19.0, 1.18.0, 1.17.1, 1.17.0, 1.16.0, 1.15.0, 1.14.0, 1.13.0, 1.12.0, 1.12.0-pre, 1.11.0, 1.10.0, 1.9.0, 1.5.0, 1.2.0, 1.1.0, 1.0.0
<script src="http://cdn.bootcss.com/qunit/2.3.3/qunit.min.js"></script>   
<link href="http://cdn.bootcss.com/qunit/2.3.3/qunit.min.css" rel="stylesheet">

Font Awesome

百度CDN

支持版本4.4.0, 4.2.0, 4.1.0, 4.0.3
<link href="http://apps.bdimg.com/libs/fontawesome/4.4.0/css/font-awesome.min.css" rel="stylesheet">

BootCDN

支持版本4.7.0, 4.6.3, 4.6.2, 4.6.1, 4.6.0, 4.5.0, 4.4.0, 4.3.0, 4.2.0, 4.1.0, 4.0.3, 4.0.2, 4.0.1, 4.0.0, 3.2.1, 3.2.0, 3.1.1, 3.1.0, 3.0.2, 3.0.1, 3.0.0, 2.0.0, 2.0, 1.0.0
<link href="http://cdn.bootcss.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">

underscore

百度CDN

支持版本1.7.0, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.3, 1.3.2, 1.3.1-amdjs, 1.3.1, 1.3.0, 1.2.4, 1.2.3, 1.2.2, 1.2.1, 1.2.0, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0, 0.6.0, 0.5.7, 0.5.5, 0.5.4, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.4.7, 0.4.6, 0.4.5, 0.4.4, 0.4.3, 0.4.2, 0.4.1, 0.4.0, 0.3.3, 0.3.2, 0.3.1, 0.3.0, 0.2.0, 0.1.1, 0.1.0
<script src="http://apps.bdimg.com/libs/underscore.js/1.7.0/underscore.js"></script>  

BootCDN

支持版本1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.0, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.3, 1.3.2, 1.3.1, 1.3.1-amdjs, 1.3.0, 1.2.4, 1.2.3, 1.2.2, 1.2.1, 1.2.0, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.4, 1.0.3, 1.0.2, 1.0.1, 1.0.0, 0.6.0, 0.5.8, 0.5.7, 0.5.6, 0.5.5, 0.5.4, 0.5.3, 0.5.2, 0.5.1, 0.5.0, 0.4.7, 0.4.6, 0.4.5, 0.4.4, 0.4.3, 0.4.2, 0.4.1, 0.4.0, 0.3.3, 0.3.2, 0.3.1, 0.3.0, 0.2.0, 0.1.1, 0.1.0
<link href="http://cdn.bootcss.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">

swfobject

百度CDN

支持版本2.2, 2.1
<script src="http://apps.bdimg.com/libs/swfobject/2.2/swfobject.js"></script>   

BootCDN

支持版本2.2
<script src="http://cdn.bootcss.com/swfobject/2.2/swfobject.min.js"></script>   
35ѡ7